Xmap для Joomla 3.X выдает ошибку Fatal error: require_once(): Failed opening required

Автор: QWNet
Категория: CMS & Кодинг Создано: 21.06.2015 20:10

В данном посте, я хотел бы рааскзаать, как устранить ошибку Fatal error: require_once(): Failed opening required, которую выдает компонент Xmap для Joomla 3.X.

 

php code Хочу поделиться небольшим, но довольно информативным постом. Если вы пользуетесь CMS Joomla, и вашу карту сайта генерирует компонент Xmap, то данный пост для вас будет полезен.

Во время разработки данно блога, я столкнулся с проблемой. После того, как компононет Xmap для Joomla 3.X (которая используется на данном блоге), был успешно установлен, он выдавал ошибку "Fatal error: require_once(): Failed opening required".

Связанно данное явление с тем, что при установке, в файл components/com_xmap/helpers/xmap.php записывается не верный путь в строке 12.

В разных случаях строка 12 имеет различное содержимое. Я не буду приводить примеры, поскольку их довольно много и все они различные. Вам просто необходимо заменить содержание данной строки на следующее:

 

require_once(JPATH_SITE .'/libraries/cms/application/site.php');

После того, как код был успешно обновлен и сохранен, переходим на страницу /index.php?option=com_xmap&view=xml&tmpl=component&id=1 и обновляем её.

Поздравляю! Проблема была успешно ликвидирована, и больше не должна повторяться.

Смотрите другие полезные вещи, как устранить какую либо ошибку в CMS, и многое другое, в категории CMS & Кодинг.


Люди, участвующие в этой беседе

Комментарии (2)

Оставьте свой комментарий

Оставить комментарий как гость

0 Ограничение символов
Размер текста должен быть больше 10 символов